CasperVend v1

From CasperTech Wiki
Jump to: navigation, search
CasperVend v1 is the predecessor to CasperVend2. The v1 system was released in September 2010, and was taken off sale in January 2012.

What Version am I Running?

If you have purchased - or updated - CasperVend since January 2012, you are NOT using CasperVend v1.
The v1 vendors are easily recognisable since they are distributed with a black theme. If your vendors came with a white template, you are using the new (v2) system.
Here is a picture of one of the V1 vendors:
Picture of a multi-panel v1 vendor
Old v1 series vendor

Decommissioning

CasperVend offers a 12 month service guarantee on all vendor purchases. As of January 2013, we fulfilled this 12 month obligation to all of our v1 customers, and therefore began decommissioning the v1 vendor network, as previously announced.
The equivalent v2 vendor system is a FREE upgrade to ALL CasperVend customers - and all your existing data on the website will automatically work with v2.
The v1 system was retired over a few months. This was a gradual decommissioning, as follows:
  • From the 1st of January, 2013, the v1 system ran at a reduced capacity, on only one server, and was subject to issues during rolling restarts. In addition, certain website services were no longer working correctly with v1 vendors (for example, the statistics and customers pages).
  • From the 1st of February, 2013, it was no longer possible to rez new v1 vendors. All existing v1 vendors that were rezzed out as of February 2013 were still functional.
  • From the 1st of March, 2013, support was no longer provided to customers still using v1 vendors. (Updating was strongly encouraged, and support was, as always, continued for current versions.)
  • From the 1st of April, 2013, we sent out repeated warnings to users who still had v1 vendors rezzed.
  • From the 1st of May, 2013, the entire v1 vendor service ceased operations. Any v1 vendors rezzed out after that point are no longer able to contact an active server, as the machines that ran the network the v1 vendors talked to is no longer in operation.

Error Message

All v1 vendors - affiliate or non - and DropBox(es), when rezzed out, will now give only this message:

  The server reported a failure. I'm going to try again in 2 minutes (or touch to try again now)

The only resolution to this error is to upgrade your vendors and DropBox(es). If you are using the affiliate/franchise vendors from another merchant, you will need to contact THAT merchant for updated vendors - You cannot upgrade v1 affiliate/franchise vendors from someone else.

How to Update

If you are the original merchant of the vendors


  1. Use the redeliver terminal at the CasperTech store (it will sort CasperTech purchases to the top)
  2. Log into your CasperVend account on the web, and redeliver from the list in the Overview tab
  3. Send an IM to CasperTech Resident to get instructions
  4. Use any other redelivery terminal (but you'll need to page through the list of what you can redeliver to find CasperVend.)


Q. Why can't I just use the UpgradeBee on the v1 vendors anymore?
A. The v2 vendors have been rebuilt and redesigned from scratch, with the buttons and panels using a different system, and therefore it is not possible to update to v2 using the bee. You will need to rez new vendors and point them to the existing listings. (You will NOT need to redo anything in your existing listings - just point new vendors to old listings.)

If you are the affiliate/franchisEE


You will need to contact the original merchant for a set of updated vendors. You are NOT able to update v1 vendors to v2, as doing to requires access to the CasperVend account to point the new vendors to the old listings.